SAP Knowledge Base Article - Public

3699599 - KUT Field Is Not Available In DWB Export Even After Adding Field To The OData Service

Symptom

The KUT field is missing from the DWB export for a specified Business Object in another language, despite the field being added to the OData service.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Data Workbench work center.
  2. Open the Export work center view.
  3. Select the relevant Business Object (e.g., Account). 
  4. Search for the impacted KUT field in the list.
  5. Observe that the field is not available.

Cause

The KUT field is not available in the DWB export because its language-dependent properties were not maintained in the preferred language under the General Data tab. Specifically, the field’s Screen Texts, List Values, and Language Description settings must be properly configured for the target language.

Resolution

For example, KUT Field is not available in DWB Export for Account object in FR language even after the field is added to the OData service.

  1. Go to Accounts and open any document.
  2. Start Adaptation Mode.
  3. Go to the KUT field layer and click on Edit button. 
  4. Update the KUT field by maintaining French translations under the General Data tab by adding the appropriate label and tooltip in the Screen Texts section.
  5. Maintain code and description in French under List Values.
  6. Ensure Language and descriptions were properly maintained in French.
  7. Click on Save and End Adaptation Mode.  

See Also

Customer Services & Support Knowledge - KUT Field Is Missing On Data Workbench Export Template | HCSM

Keywords

KUT field, DWB Export, Not Available, Missing, Language , KBA , LOD-CRM-INT-DWB , Data Workbench , Problem

Product

SAP Cloud for Customer core applications all versions