SAP Knowledge Base Article - Public

3699616 - How to Examine Interrupted Tasks in Data Workbench.

Symptom

Data Workbench tasks are being interrupted when filtering by ID.

Environment

SAP Cloud for Customer 

Reproducing the Issue

  1. Go to Data Workbench Export
  2. Select BO Task
  3. Enter task ID 
  4. Click export data
  5. Go to Monitor
  6. The status is Interrupted

Cause

The interruption occurs due to the extension field.

Resolution

1. Check if the following OData URL is working fine: https://<mytenantid>.crm.ondemand.com/sap/c4c/odata/v1/activity/TasksCollection?$filter=ID eq '<value>'

2. If it is, then verify whether the metadata for the Tasks BO contains duplicate extension fields. Additionally, for fields with a decimal property, ensure that their values are maintained correctly according to the defined precision and scale <mytenantid>.crm.ondemand.com/sap/c4c/odata/v1/activity/$metadata

Keywords

Data Workbench Tasks, Interrupted, C4C , KBA , LOD-CRM-INT-DWB , Data Workbench , Problem

Product

SAP Cloud for Customer core applications all versions