Symptom
When the field 'Account First Name' is set to the Account's description name and used as a condition for triggering a Workflow Rule within Tickets, the Workflow is not being triggered as expected.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service >Tickets.
- Open the desired Ticket.
- Perform the steps to trigger the Workflow Rule.
- Go to Workflow Changes tab.
- See Workflow is not triggered.
Cause
The Workflow Rule was not being triggered because when using Account/Individual Customer description the 'Customer' field should be used instead.
Resolution
This is the system expected behavior.
In order to trigger the Workflow Rule for any Account with name "ABC" then you can use condition as below:
- Customer Matches Pattern "ABC"
However, in order to trigger it only for a specific Account ID, then it is possible to maintain the conditions as:
- Customer ID Equal to "123"
Keywords
WKF, account, ticket, condition, customer, does not trigger, not triggering, didn't trigger, do not trigger, triggered, not working, did not work, does not work, do not work, don't work , KBA , LOD-CRM-WKF , Workflow , Problem
SAP Knowledge Base Article - Public