Symptom
You would like to have a custom determination to set the status of a Case to "Completed" immediately upon its creation. Specifically, the status should change from 'Open' to 'Completed' as soon as the case is created.
Environment
SAP Service Cloud Version 2
Reproducing the Issue
1. Click on the User Icon.
2. Go to Settings > All Settings.
3. Go to Extensibility Administration.
4. Select Case Service > Case.
5. Go to the Determinations tab.
6. Create a Rule to change {status} from 'Open' to 'Completed' status immediately after creation.
7. Go to the Case Object Worklist (OWL).
8. Click on "+".
9. Fill required information.
11. Click to Save.
12. The Status does not go to "Completed".
Cause
Currently, the system does not support creating a Case with the Status already set to 'Completed'. Therefore, the Determination rule does not function as expected during the Case creation process but should be effective for subsequent updates.
Resolution
As an alternative solution, you can use Autoflows to achieve the desired functionality. Autoflows can automatically update the Case status to 'Completed' shortly after its creation.
For more information on setting up and configuring Autoflows, please refer to the following documentation: Autoflow
See Also
Keywords
Case Management, Case Creation, Determination, Case Status, Status Change, Open Status, Completed Status, Autoflows, Automation, Worklist, Extensibility Administration, Case Object Worklist, OWL, Business Rules, System Limitations, Troubleshooting, Settings Configuration, SAP CX, Help Documentation. , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CZM-CUL , Custom Logic for for SAP Sales/Service Cloud , Known Error
SAP Knowledge Base Article - Public