SAP Knowledge Base Article - Public

3700304 - Unable to locate line items using inbound delivery notification ID in return to supplier

Symptom

Unable to find line items when searched using Inbound Delivery Notification ID in the new return to supplier screen.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the Purchase Requests and Order work center.
  2. Select the New Return to Supplier common task.
  3. Search using the Inbound Delivery Notification ID ABC (ABC represents Inbound Delivery Notification ID)
  4. Observe that no results are found.

Cause

Scenario 1: Select Supplier Delivery Items By selection and search with Inbound Delivery Notification ID with and without * symbol, it gives "No records found".

Scenario 2: Select Third-Party Customer Return items by selection and search with Inbound Delivery Notification ID with and without * symbol, it gives "No Records found".

Scenario 3: Click on advanced filters and Search with respective document in Inbound Delivery Notification ID field it gives the expected line items.

This is a system-expected behavior.

Resolution

Note that searching with Inbound Delivery Notification ID in the basic search will not give desired results.

So use the Advanced Search filters option to locate the desired document while creating a "Return to Supplier".

Now in order to search with Inbound delivery notification ID, It can taken as a new requirement and you can post in SAP Business ByDesign influence forum

Keywords

return to supplier, inbound delivery notification, IDN, advanced search, line items, no records found, search filters, system behavior , KBA , AP-RTS , Return To Supplier , Problem

Product

SAP Business ByDesign all versions