SAP Knowledge Base Article - Public

3700735 - Inline image upload functionality not available in mobile application

Symptom

Users are unable to upload images in the Ticket object when using the Mobile Application. The inline image functionality works as expected in the Web Application but is not available in the Mobile Application.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Cloud for Customer

Reproducing the Issue

Issue can be raised in any objects, take Ticket BO as an example.

  1. Open the Ticket work center.
  2. Navigate to the impacted facet which included the text editor.
  3. Enter edit mode.
  4. Attempt to insert an image.
  5. Observe that the image upload functionality is not available in mobile, which available in web browser.

Cause

The inline image upload feature in the rich text editor is not available for mobile applications due to technical limitations.

Resolution

This behavior is currently expected within the platform's design.

See Also

3040815 - Not able to attach files from Local Drive in C4C Mobile App

Keywords

inline image upload, mobile application, rich text editor, ticket summary form, image insertion, mobile browser, mobile app, functionality limitation, web application, android, ios, ipad, technical limitation , KBA , AP-RC-MOB-AND , SAP Hybris Cloud for Customer Extnd App on Android , Problem

Product

SAP Cloud for Customer core applications all versions