Symptom
- An extension field was added in the item node of the Dunning business object is only visible in the Receivable Item node under Dunning Item of the dunning template.
- The custom field is not visible in the Reminder Item and Non-Due Item nodes of the dunning template.
Environment
- SAP Business ByDesign
- SAP Cloud Applications Studio
Reproducing the Issue
- Create a custom field named in the item node of the Dunning business object.
- Enhance the field to the dunning templates.
- Open the templates in Adobe Lifecycle Designer.
- Observe that the custom field is visible in the Receivable Item node under Dunning Item but not in the Reminder Item and Non-Due Item nodes.
Cause
The extension field created in the SDK is not automatically extended to the Reminder Item and Non-Due Item nodes due to limitations in the HTML5 OBERON version.
Resolution
- Log into SAP Cloud Applications Studio and open the relevant solution.
- Right-click on the field created in the SDK and select "Enhance Form".
- Ensure the correct field is selected and click "OK".
- In the browser window, log in with the same SDK user.
- Modify the browser URL by replacing "HTMLOBERON5" with "HTML5" and press Enter.
- Wait for the UI to fully load and click "Adapt > Launch in Fiori Client".
- In the Fiori Client window, select the any template variant and click "Add Field and Edit > Easy Form Editor".
- Repeat the process for each variant location to add the field to the Reminder Item and Non-Due Item form structures.
Note: If the template variant was created in the UI by the business user, create a new template as a copy of an example template to replicate the form structures.
Keywords
custom field, dunning template, reminder item, non-due item, visibility issue, SDK enhancement, Fiori client, HTML5, Adobe Lifecycle Designer, ByDesign Studio , KBA , AP-RC-BDS-OM , ByDesign Studio Output Management(Forms) , SRD-FIN-ACR , Receivables , AP-RC-OUT , Output Management , Problem
SAP Knowledge Base Article - Public