SAP Knowledge Base Article - Public

3700869 - Talent Intelligence Hub: newly created competency can't be mapped to a Job Role or Job Profile

Symptom

An error occurs when attempting to map a newly created competency in Talent Intelligence Hub (TIH) to a Job Role/Family or Job Profile.

Error message: "Competency is not successfully migrated to Talent Intelligence Hub."

Environment

SAP SuccessFactors Talent Intelligence Hub

SAP SuccessFactors Job Profile Builder

Reproducing the Issue

  1. Upgrade to Talent Intelligence Hub.
  2. Create a new competency in Talent Intelligence Hub after migration.
  3. Attempt to map this new competency to a Job Role/Family or Job profile.
  4. Observe the error message: "Competency is not successfully migrated to Talent Intelligence Hub."

Cause

Competencies are not synchronised from TIH back to JPB, this is caused by Competency Object Definition configuration.

Resolution

  1. Navigate to Configure Object Definitions.
  2. Select Object Definition -> Competency (CompetencyEntity).
  3. Under fields, select capabilityGroup.
  4. Go to Details and set Required field to No.

Keywords

TIH, talent intelligence hub, JPB, Job Profile Builder, new competency, TIH competency, competency mapping error, job role mapping issue, competency migration error, mapping competency, competency entity configuration, capabilityGroup field, mapping issue, Configure Object Definitions, not required field. , KBA , LOD-SF-TIH-JPB , Job Profile Builder , How To

Product

SAP SuccessFactors Performance & Goals 2511 ; SAP SuccessFactors Succession & Development all versions