Symptom
- Some users in SAP Analytics Cloud (SAC) are unable to open the Data Analyzer from a Story.
- The issue occurs only when opening the visualization in a new browser tab.
- For the same users, the Data Analyzer opens correctly when the visualization is opened in the same browser tab.
- Other users with identical authorizations do not experience the issue, for them, the Data Analyzer opens successfully in both scenarios.
- The following error appears in the console traces when the issue occurs: "[IOLayer]: (#1019) OAUTH_POPUP_BLOCKED, Error [Protocol]: (#73) No response object given."
Environment
-
SAP Analytics Cloud (Enterprise)
Reproducing the Issue
- Open a Story in SAP Analytics Cloud (SAC).
- Attempt to open the Data Analyzer from the Story in a new browser tab.
- Observe that the Data Analyzer fails to open for certain users.
- Verify that the same users can open the Data Analyzer successfully when using the same browser tab.
Cause
- Pop-ups and Redirects in Browser were disabled by default by the browser.
Resolution
Pop-ups and Redirects in Browser needs to be set to Allow.
- Guide: Enable Pop-ups and Redirects in Browser:
- For Chrome:
- Go to Settings → Privacy & Security → Site Settings → Pop-ups and Redirects.
- Click Add under “Allowed to send pop-ups and use redirects.”
- Enter your SAC and Datasphere URLs (e.g.,
https://<your-sac-domain>andhttps://<your-datasphere-domain>).
- For Edge:
- Settings → Cookies and Site Permissions → Pop-ups and Redirects.
- Add SAC and Datasphere URLs under Allow.
- For Chrome:
Keywords
SAP, SAC, data analyzer, sap analytics cloud, story, new browser tab, pop-ups, redirects, oauth_popup_blocked, protocol error, browser settings, visualization, authentication issue, sac functionality , KBA , LOD-ANA-DES , Story Design & Visualizations , Problem
Product
SAP Analytics Cloud all versions
SAP Knowledge Base Article - Public