Symptom
- Users are unable to reset their passwords via the "Forgot Password?" option when choosing Email and entering their email address.
- No email notification is received when choosing Email and entering the email address in the "Forgot Password?" page.
- Password reset functionality works when the username is entered instead of the email address in the "Forgot Password?" page.
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Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Navigate to the login page for SuccessFactors and click on "Forgot Password?".
- Select "User Name" and enter the user's username, then click on "Continue". An email notification is sent to the user's email address.
- Select "Email" and enter the user's email address, then click on "Continue". No email notification is sent to the user's email address.
Cause
The setting "Enable CAPTCHA for the Forgot Password page" is enabled in Password & Login Policy Settings. This setting conflicts with the password reset by email functionality, preventing users from receiving password reset emails when entering their email address.
Resolution
The fix for this issue is planned to be deployed on 1H 2026 release.
Workaround:
- Go to Password & Login Policy Settings page.
- Locate the setting "Enable CAPTCHA for the Forgot Password page".
- Disable the "Enable CAPTCHA for the Forgot Password page" setting by choosing "N/A".
- Test the "Forgot Password?" functionality by entering the user's email address. Verify that the email notification is successfully received.
See Also
Keywords
forgot password, email notification, password reset, , password policy settings, enable captcha, forgot password page, INC18018127, PLA-55600 , KBA , LOD-SF-PLT-PWD , Password Policy Settings & Reset Password , Problem
SAP Knowledge Base Article - Public