SAP Knowledge Base Article - Public

3702170 - After Manager change, new manager is unable to access the form using the link received in the document routing notification.

Symptom

A form was transferred to a new manager, and the [[DOC_ACCESS_URL]] generated doesn't allow the new manager to access the form throwing an error: "You do not have permission to access the form".

Manager can access the form from their inbox without any issues. 

Environment

SAP SuccessFactors Performance & Goals

Reproducing the Issue

  1. Transfer a form to a new manager.
  2. Generate the routing notification email containing the [[DOC_ACCESS_URL]].
  3. Proxy as the new manager and click the link provided in the email.
  4. Observe the error message stating "You do not have permission to access the form".
  5. Access the inbox of the New Manager and identify that form is available for access.

Cause

The email notification triggered during the form routing process retains the form id associated with the old manager instead of updating it to the new manager's form id.

Resolution

A fix for this issue has been developed and is scheduled for in 1H 2026 (2605) release.

  • Preview release: April 13
  • Production release: May 15 - 16

For release timelines, please review SAP SuccessFactors Product Release & Road Map Information.

See Also

Keywords

KI1H2026, PMU-26929, new manager, permission error, document routing, [[DOC_ACCESS_URL]], form transfer error, sap sf, pm, LOD-SF-PM-EML, You don't have permission, manager transfer , KBA , LOD-SF-PM-EML , Emails and Notifications , Known Error

Product

SAP SuccessFactors Performance & Goals 2511