Symptom
- When accessing "Manage Career Site Builder" via Admin Center/People Search, the system redirects to the home page instead of the Career Site Builder (CSB).
- Error message observed in Command Center Process logs: "RCM userSync service returned err responseHTTP Err Status: 403".
Environment
SAP SuccessFactors Recruiting Marketing
Reproducing the Issue
- Navigate to Admin Center
- Select "Manage Career Site Builder".
- Observe that the system redirects to the home page instead of the Career Site Builder (CSB).
Cause
Permissions for the RMK technical user used to run recruiter synchronization operations are missing in the database.
Resolution
The root cause of the missing permissions is being investigated with a view to a permanent fix. A workaround consists in refreshing the Technical User's permissions. To do so:
- Disable RMK in Provisioning:
Navigate to Provisioning -> Company Settings.
Uncheck "Recruiting Marketing".
Click Save. - Enable RMK in Provisioning:
Return to Provisioning -> Company Settings.
Re-check "Recruiting Marketing".
Re-check the 3 child checkboxes.
Click Save. - Run the Recruiter synchronization job:
After enabling RMK, run the Recruiter synchronization job from Command Center. - Retry accessing Career Site Builder:
Once the job has successfully completed, navigate to Career Site Builder from Admin Center again.
See Also
Keywords
career site builder, CSB access issue, redirect to home page, RMK permissions, recruiter synchronization job, security key length, provisioning settings, RMK enable, RMK disable, userSync error, HTTP error 403 , KBA , LOD-SF-RMK-CSB-RBP , CSB Role Based Permissions , Problem
SAP Knowledge Base Article - Public