Symptom
The certificate of SAML IDP of SAC expired, when upload the new IDP metadata in IDP Admin Tool to update, got error "Sorry, we were unable to upload the metadata file. Please try again."
Environment
- SAP Analytics Cloud (Enterprise)
- Identity Provider Administration Tool (IDP Admin Tool)
Reproducing the Issue
- Login to IDP Admin Tool.
- Upload the IDP metadata.
- Got error "Sorry, we were unable to upload the metadata file. Please try again."
Cause
- Multiple certificates exists in the metadata file, one of them expired.
Resolution
- Verify the validity of the metadata file and ensure that all X.509 certificates are valid.
- Provide a valid metadata file containing valid X.509 certificates.
- Upload the new metadata file to the SAC tenant subaccount to re-establish trust between the SAC tenant and the custom IdP.
- Confirm successful upload and verify access to the SAC system.
See Also
Keywords
SAML certificate issue, SAC production system, custom IdP metadata, metadata upload failure, x509 certificate expired, Identity Provider Administration Tool, SAC tenant subaccount, authentication issue, login issue, metadata file update, certificate not valid , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem
Product
SAP Analytics Cloud all versions
Attachments
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SAP Knowledge Base Article - Public