Symptom
- A configured token is missing from the email notification generated by an Alert Message for a custom MDF object.
- The token does not appear in the workflow notification for a custom MDF object.
Environment
SAP SuccessFactors HCM Suite
Cause
- The rule alert is configured to be triggered on a child object instead of the parent object.
- In Configure Object Definitions, the AlertMessage object does not have a maximum length defined for the alertDescription field.
- The configured token is not supported.
Resolution
- Ensure that the rule alert is configured on the parent object, not on a child object.
- In Configure Object Definitions, search for the AlertMessage object and verify that the alertDescription field has a maximum length of 4000 configured.
- Confirm that the configured token is supported. The list of supported tokens is available in SAP Help Creating Legacy Alert Messages. Any other token that is not listed in the SAP Help page is not supported and will not be displayed.
See Also
- SAP Help Creating Legacy Alert Messages
- 2087503 - Customizing Email Notifications Default Template Text
- 3434427 - Token [[SUBJECT_USER]] not showing on Alert Message [Custom MDF]
Keywords
token, alert message, mdf alerts, unsupported token, displayed, mdf, custom MDF notification, alert message missing token, workflow, tag , KBA , LOD-SF-MDF-ALR , MDF Alerts , Problem
Product
SAP SuccessFactors HCM Suite all versions
SAP Knowledge Base Article - Public