Symptom
- Partner functions are not added under the specified sales area during Mass Maintenance of business partners.
- The process appears successful, but no changes are applied to the customer data.
- No error messages are displayed during the process.
Environment
SAP MDG, Consolidation and Mass Processing
Reproducing the Issue
- Open the "Mass Maintenance - Business Partners" application.
- Provide a description for the process.
- Upload the provided template file.
- Follow the guided procedure until completion.
- Verify the changed data; it appears empty.
- Check the customer master; the partner functions are not visible under the specified sales area.
Cause
- The ASSIGNMENT_ID field in the uploaded template file was not populated, resulting in incorrect mapping of partner functions to the customer assignment of the business partner.
- The Business Partner number was incorrectly entered in the field intended for the Contact Person number (PARNR field).
Resolution
- Ensure the ASSIGNMENT_ID field is populated correctly in the template file.
- Verify that the Contact Person number is entered in the PARNR field instead of the Business Partner number.
Retrieve the Contact Person number from the "Maintain Business Partner" application by selecting the Customer Sales role and navigating to the relationships section.
See Also
Refer to: a href="https://me.sap.com/notes/0000560499" SAP Note 0000560499 - Customer Interaction Center: Hotline - Email - Chat /a
Keywords
mass maintenance, business partner, partner functions, assignment ID, PARNR field, customer data, template file, sales area, contact person number, mapping error, SAP S/4HANA , KBA , CA-MDG-CMP-BP , Business Partner , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public