SAP Knowledge Base Article - Public

3703672 - Incorrect email template sent during onboarding process - Onboarding

Symptom

An incorrect email template is sent to the wrong recipient during the onboarding process.

Environment

SAP SuccessFactors Onboarding

Cause

The issue occurred due to an attachment rule in the email template. The document attached by the rule contained double underscores "__" in its name, which conflicted with the system's internal use of "__" as a delimiter, preventing the attachment rule from functioning correctly.

Resolution

  1. Disable the attachment rule and verify that the email is triggered successfully without the attachment.
  2. Rename the document in "Manage Documents" by removing the double underscores "__".
  3. Update the attachment rule to select the renamed document.
  4. Review other email templates associated with the email trigger to ensure no similar document naming issues exist.

See Also

Refer to: SAP Knowledge Base Article 3597495 - Onboarding emails being sent to the incorrect recipient

Keywords

email template mismatch, onboarding email issue, sap successfactors onboarding, car parking email, bike cage email, attachment rule conflict, document naming issue, email subject and body mismatch, onboarding process error, notifications framework , KBA , LOD-SF-OBX-NF , Notifications Framework , Problem

Product

SAP SuccessFactors Onboarding all versions