SAP Knowledge Base Article - Public

3703756 - Some particular users can not search in library in new learning homepage

Symptom

  • Users are unable to search for training in new learning homepage.
  • Error shows that "Unable to load data".
  • When capturing the network log, it shows a 500 error with error message like "co.elastic.clients.json.JsonpMappingException: Error deserializing co.elastic.clients.elasticsearch._types.query_dsl.TermsQuery: jakarta.json.stream.JsonParsingException: Unexpected char 50 at (line no=25, column no=390, offset=850) (JSON path: query.bool.should[1].nested.query.bool.must[0].terms['learning_item_class.catalogs'][12]) (line no=25, column no=391, offset=851)"

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Login as the user with problem
  2. Go to library and search for any items
  3. Error "Unable to load data" is displayed

Cause

  • The issue is caused by the presence of a prohibited character "\" in the library ID associated with the user's accessable library.

Resolution

  1. Remove the library access from the user.
  2. Alternatively, recreate the library ID by replacing the prohibited character "\" with an allowed character, such as "_".
  3. Verify the resolution by ensuring the user can search for training successfully.

Keywords

Training search issue, LMS, integrated learning management system, library ID, prohibited character, user access rights, search functionality, training module, resolution steps, library ID error, search error, Unable to load data, 500, Unexpected char, learning_item_class.catalogs , KBA , LOD-SF-LMS-ILX , Integrated Learning Experience , Problem

Product

SAP SuccessFactors Learning all versions