SAP Knowledge Base Article - Public

3703980 - No payload data in Web Service Message Monitoring for Synchronous Messages

Symptom

In C4C Webservice Message Monitor, for synchronous messages, the payload is always empty. 

Environment

SAP Cloud For Customer

Reproducing the Issue

  1. Goto Administrator -> General Settings -> Web Service Message Monitoring
  2. Select the relevant message and click on View Payload
  3. A pop-up called "Payload" is displayed, but it's empty and the button "Download" is grayed out.

Cause

In case of synchronous web service calls: Request – Response type of web service calls. This type of service execution provides an immediate response to a query. In this situation, the client (external application) will wait until the server (C4C) sends back the response message.

Successful calls of this type are not recorded by default in web service message monitoring for the primary reason that the source system will get an instant response with the result of the transaction. Failed calls will be logged on web service message monitoring which are raised by SOAP Run-time (such as parsing errors), but the payload contents are not stored.

Resolution

The A2X trace internal function in C4C must be active when the request payload is triggered in order to save the payload contents. To activate it, in Web Service Message Monitoring, click on the three dots on the top right-hand side -> "Start Trace"; then reproduce the issue. This will activate the internal trace for 30 minutes. 

The payload contents should be visible in the monitor after that the request was triggered.

Keywords

KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer core applications 2508