SAP Knowledge Base Article - Public

3704575 - Newly created custom field cannot be seen in SAPGUI apps

Symptom

After creating one custom field for one of the bellow business contexts:

  • Sales: Sales Document Item (SD_SALESDOCITEM)
  • Sales: Sales Document (SD_SALESDOC)

The field cannot be seen in the app Display/Change Sales Documents (VA03/VA02), in the custom fields tab. Also when trying to add the field through UI adaptation, the field was also not available.

Environment

SAP S/4HANA Cloud Public Edition

Cause

The custom field created was not enabled for the necessary user interface.

Resolution

To enable the custom field to the mentioned apps, follow bellow steps:

  1. Enter the custom fields app and search for the created custom field.
  2. Go into 'User Interfaces' tab.
  3. Go into 'SAP GUI' tab.
  4. Enable the option 'SD_SALESDOCITEM_GUI'.
  5. Save and publish.

Keywords

display sales orders, change sales orders, create sales orders, VA03, VA02, VA01, SAP GUI, old version, flavor, adapt ui, extensibility, SD_SALESDOCITEM_GUI, Sales: Sales Document, SD_SALESDOC, Sales: Sales Document Item, SD_SALESDOCITEM , KBA , SD-SLS-EXT-2CL , Extensibility (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions