Symptom
- Tags are visible in the warning message during the Personal Data Collection (PDC) step in Onboarding.
- The warning message related to a particular portlet shows the unresolved tag.
- The same portlet does not display unresolved tags when accessed directly in Employee Central (EC).
- A message, triggered from a Business Rule, containing HTML tags shows the tags as simple text.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as Onboardee.
- Navigate to the Personal Data Collection (PDC) step.
- Submit PDC step.
- Observe the warning message triggered, displaying unresolved tags.
Cause
Not all the User Interfaces inside of SuccessFactors are able to interpret the HTML codes inserted in the message definitions.
Resolution
This is a bridge KBA, where the existing resolution was illustrated in the following article:
2250044 - Using HTML Tags in Message Definition of Business Rule for custom MDF Object
See Also
Keywords
tag, message, onboarding, personal data collection, unresolved tags, employee central, message definitions, mdfSystemExternalUserVisibility, external user visibility, sap successfactors onboarding, Bridge KBA, OBX, PDC, HTML Codes, HTML, Object, record, warning, error, business rules, raise message , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem
SAP Knowledge Base Article - Public