Symptom
- An error occurs in the business process after initiating onboarding.
- Error message: {"responsePayload":[{"userSysId":"xxxx","hrisSaveStatus":[{"elementType":null,"key":null,"statusCode":"ERROR","errorInfo":"Event Reason is mandatory for jobInfo"}]}]}.
- The error is related to the job info for auto-setting the event reason.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as support user.
- Initiate onboarding process.
- Observe successful initiation followed by an error message in the business process within To-do tile.
- View error message related to event reason in job info.
- Check the job info model in "Manage business configuration" and confirm the rule is present.
- Restart the process in the business process.
- Observe that the error persists.
Cause
Event Reason is not enabled within Manage Business Configuration.
Resolution
- Navigate to "Manage Business Configuration".
- Locate the Event Reason field under job info.
- Enable the Event Reason field.
- Save the changes.
- Restart the onboarding process and verify if the issue is resolved.
See Also
Keywords
event, reason, job, info, onboarding, error, mandatory field,HRIS data, business process ,configuration , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , LOD-SF-RCM , Recruiting Management , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public