SAP Knowledge Base Article - Public

3705076 - "No data available. Try adjusting the filter settings. : Table found but no data" Error During Automated Test

Symptom

Your are working with automated tests, and notices a test process failed with the following error in the execution logs:

"No data available. Try adjusting the filter settings. : Table found but no data"

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the Test Your Processes - Manage Test Plans app.
  2. Select the test plan.
  3. Open the Logs tab.
  4. Check the error log in the test process.

Cause

During the test process execution, a step is performing a search or a filter in a list (for example, filtering for documents created in the last 24 hours).

However the results of the search/filter have no records, which prevents subsequent steps from being executed.

Resolution

Check the parameters being used during the test process steps, in order to ensure that searches and filters have at least a single result.

It is suggested to avoid time-dependent searches (such as filtering documents created within a certain timeframe), and prioritize searches for IDs of objects that already exists, in order to ensure consistency during the test execution.

Keywords

PUT, test step, action , KBA , CA-CTT-S4C , CTT-Customer Test Tool, S4C-START for S/4HANA CE , Problem

Product

SAP S/4HANA Cloud Public Edition all versions