Symptom
The registered products in service order ABC are not visible in the data source "CRMSORIB" (ABC represents the ID of the service order)
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Service Orders work center.
- Go to the Service Order Processing view.
- Search for the service order "ABC." (ABC represents the ID of the service order)
- Click "Edit," and navigate to the General tab.
- Under the "Accounts and Affected Product" sub-tab, the affected products are listed; for example, 8 registered products are maintained, with one designated as the main product.
- Navigate to the work center: Business Analytics.
- Select the view: Data Sources.
- Set the display to Show: All.
- Search for the data source "CRMSORIB" and click "Preview."
- In the selection criteria, enter the service order "ABC." (ABC represents the ID of the service order)
- Select the following fields for viewing:
- Service Order
- Affected Registered Product
- Registered Product ID
- Main
It will be observed that only the main registered product is displayed.
Cause
The data source "CRMSORIB" includes a query definition designed to retrieve the main registered product.
Resolution
The expect system behavior.
There are no other special reports available that display the other registered products associated with a service order.
Keywords
Data source, service order , KBA , SRD-CRM-ORD , Orders & Contracts , Problem
Product
SAP Business ByDesign all versions
SAP Knowledge Base Article - Public