SAP Knowledge Base Article - Public

3705827 - Not possible to edit the "Item category" field anymore after a subsequent document was created - SAP S/4HANA Cloud Public Edition

Symptom

After creating a sales document (e.g. sales order, sales quotation, etc), it is possible the item category field, however, when a subsequent document is generated, the item category field in the previous document iis greyed out and can't be edited anymore.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Create a sales scheduling agreement.
  2. Define the item category of the material.
  3. Create a subsequent document (Correction delivery, for example).
  4. Try to edit the previous Sales Scheduling agreement.
  5. See that the item category field is now greyed.

Cause

Standard system behavior.

"The item category field influences the determination of many fields within the sales document and will also impact the processing of path of subsequent documents."

Some fields are already set to not ready for input in the screen definition, others are closed due to a certain order status, since those fields are dependent within one another, to prevent data inconsistencies, they are greyed out after a subsequent document is generated.

Resolution

Edit the fields necessary before creating a subsequent document with reference to the original document.

See Also

 

Keywords

item, category, edit, grey, out, change, document, subsequent, order, status, sales, order, scheduling, agreement, quotation,  , KBA , SD-SLS-OA-SCH-2CL , Customer Scheduling Agreement (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions