SAP Knowledge Base Article - Public

3706176 - Intelligent Q&A in SAP CX AI Toolkit does not return answers when integrated with SAP Cloud for Customer

Symptom

  • Intelligent Q&A in SAP CX AI Toolkit does not return answers for Cases or Opportunities queries.
  • The integration works correctly for other tools.

Environment

SAP CX AI Toolkit

Reproducing the Issue

  1. Open Intelligent Q&A
  2. Set Source Location to SAP Sales and Service Cloud → Cases (toggle ON).
  3. Ask a Cases/Opportunities query (e.g., “show my open cases” / “status of case ”).
  4. Observe no answer/result returned.

Cause

The "number of records to onboard" in the CX AI Toolkit configuration cannot set to "0".

Resolution

  1. Access the SAP CX AI Toolkit configuration Settings.
  2. Under Sales and Services tab Click on Edit icon from the Entity affected (sap.crm.opportunityservice.entity.opportunity or sap.crm.caseservice.entity.case)
  3. Locate the "number of records to onboard" Option in the popup.
  4. Change the selection from "0" to a valid number of records to onboard.
  5. Save the configuration changes.

See Also

Help Center Document Link : https://help.sap.com/docs/cx-ai-toolkit/set-up/configuring-entities-for-sap-sales-and-service-cloud-version-2?locale=en-US&version=LATEST 

Keywords

sap cx ai toolkit, intelligent q&, case-related queries, sap service cloud v2, source location, no answers returned, number of records to onboard, configuration settings, troubleshooting, integration failure, case queries , KBA , CEC-AIT , SAP CX AI Toolkit , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions