Symptom
- Help document for SAP Analytics Cloud, add-in for Microsoft Excel
- Release Plan
- Trouble-shooting steps
- Errors:
- SAC Add-in Related:
- add-in is outdated
- Get-OrganizationAddInOverrides: There was an error retrieving Add-Ins
- There was an error uploading the Add-in AddInOverridesCreationException
- SAC addin not loaded under Office Add-in - ADMIN MANAGED page
- Office Add-in - ADMIN MANAGED page: Cannot connect to catalog.
- some users get the message "No add-ins currently available' within the 'Admin Managed tab for the 'Office Add-ins'
- Powershell: The Organization Add-in Service sessions was not initialized. Please call the Connect - OrganizationAddInService commandlet first
- Powershell: CategoryInfo NotSpecified: (:) AggregationException "Loading Add-ins"
- Desktop version: "We can't start the add-in because it isn't set up properly. Add-in name: SAP Analytics Cloud"
- Web version:"We couldn't get the information needed to start this add-in"
- Add-in Error Something went wrong and we couldn't start this add-in. Please try again later or contact your system administrator
- Microsoft 365 has been configured to prevent individual acquisition and execution of Office Store Add-ins
- "SAP Analytic Cloud" is not shown in Desktop version of Excel
- Go to Excel - More - Add-ins, the "Admin Managed" section is missing
- SAC logon Related:
- Go button is grayed out
- go! button disabled
- panel is empty
- blank screen, blank window
- connection failed when VPN enabled
- HTTP status code: Forbidden" when trying to configure the SAC tenant in PowerShell
- add-in restart
- SAC Function Related:
- live data source not found
- cannot access workbook
- Comments are not supported for this table since it has dimensions with members exceeding the admin configured limit; please contact your administrator
- An error occurred while loading the data sources of system <systemname>. Therefore, no data sources can be shown.
- SAC Performance Related:
- connection slow
- add-in crash due to memory limit
- SAC Add-in Related:
- How to trace in Excel add-in
Environment
SAP Analytics Cloud, add-in for Microsoft Office
SAP Analytics Cloud, add-in for Microsoft Excel
Cause
- Missing Configurations
- Network Disruption like VPN or Azure Service
- Missing Functions
- Deploy delay in Microsoft Infrastructure
Resolution
- System Requirement
- Online Help
- SAP Analytics Cloud:
- SAP Analytics Cloud, add-in for Microsoft Excel
- Microsoft Excel
- Microsoft 365
- Microsoft recommends moving interactive devices to Monthly Enterprise Channel or Current Channel.
- Semi-Annual Enterprise Channel is shifting to focus on unattended devices.
- 3597802 - How to check the current release of Microsoft 365 Apps
- See "Important Section":
- Trouble-Shooting
- Check if domains is accessible in cooperation network (for example: [assets.sapanalytics.cloud appsforoffice.microsoft.com hcs.cloud.sap])
- Check Firewall
- Check Proxy configuration
- Check VPN
- Check Azure disruption:
- Check Current Status: https://azure.status.microsoft/en-us/status/
- Review history:https://azure.status.microsoft/en-us/status/history/
- Check Microsoft known issue:
- Check Central Deployment:
- Workaround:
- Delete the Add-in from the users machine
- Remove the users from the central deployment
- Add them again
- Select again the Add-in from the users machine
- Remove office cache if not success
- Related Error:
- Add-in Error Something went wrong and we couldn't start this add-in. Please try again later or contact your system administrator
- Microsoft 365 has been configured to prevent individual acquisition and execution of Office Store Add-ins
- "SAP Analytic Cloud" is not shown in Desktop version of Excel
- Go to Excel - More - Add-ins, the "Admin Managed" section is missing
- Workaround:
- Check Tenant Configuration
- Check if it is Admin user that runs add-in deployment in Powershell
- related error: HTTP status code: Forbidden" when trying to configure the SAC tenant in PowerShell
- Deploy and publish the add-in as administrator
- Check Tenant Domain:
- tenant URL with the standard domain hcs.cloud.sap can be used without any additional configuration
- tenant URL with domain sapanalytics.cloud and hanacloudservices.cloud.sap must be manually configured by Microsoft365 administrator
- see Tenant Configuration
- Tenant Configuration related error:
- AppDomain Configuration
- See Step 5 in 3255665 - SAP Analytics Cloud tenant configuration and troubleshooting
- Get-OrganizationAddInOverrides: There was an error retrieving Add-Ins
- How to Test:
- Open the PowerShell and connect to your Microsoft365 tenant by running the command Connect-OrganizationAddInService and authenticate with a Microsoft365 administrator
- Run the following command: Get-OrganizationAddInOverrides -ProductId 8a512e2b-c04e-4c06-9235-11b6cd59f584
- Confirm that the affected SAC tenant URL(s) is listed in "AppDomains" in the output
- see sample in 3255665 - SAP Analytics Cloud tenant configuration and troubleshooting
- see sample in 3255665 - SAP Analytics Cloud tenant configuration and troubleshooting
- AppDomain Configuration
- Check if it is Admin user that runs add-in deployment in Powershell
- Check if trusted origins sites are configured in SAC tenant:
- go to SAC tenant and choose System Administration - App Integration - Trusted Origins.
- make sure the following sites as trusted origins:
https://hcs.cloud.sap
https://*.live.com
https://*.online.office.de
https://*.sharepoint.com
- Related Error: go! button disabled
- Check if all users are at the same up-to-date SAC add-in version (If the issue is happening to some user not all users):
- Check if the affected user has the latest Excel version: SAP Analytics Cloud for Excel
- From HAR trace file, you can check the landing page entry:
- for example, https://SAC tenant URL/sap/fpa/ui/office/office.html?landingPageUrl .....&landingPageVersion=1&addinVersion=X.XX.XX
- From HAR trace file, you can check the landing page entry:
- If the affected user has the Excel add-in directly loaded from the Microsoft store, user should click the "Remove" option and wait until the centrally deployed add-in gets visible in Excel
- If it is not happening, please contact Microsoft support
- If the users do not get centrally deployed SAC add-in with same up-to-date SAC add-in version, please contact Microsoft support.
- If the user already has the centrally deployed add-in, user will need to clear the add-in cache once more.
IMPORTANT: close allother MS apps (Outlook, Word, OneNote, PowerPoint, ...) and then use the option in Excel to clear the cache. - Related Errors:
- SAC addin not loaded under Office Add-in - ADMIN MANAGED page
- Office Add-in - ADMIN MANAGED page: Cannot connect to catalog.
- some users get the message "No add-ins currently available' within the 'Admin Managed tab for the 'Office Add-ins'
- Powershell: The Organization Add-in Service sessions was not initialized. Please call the Connect - OrganizationAddInService commandlet first
- Powershell: CategoryInfo NotSpecified: (:) AggregationException "Loading Add-ins"
- Desktop version: "We can't start the add-in because it isn't set up properly. Add-in name: SAP Analytics Cloud"
- Web version:"We couldn't get the information needed to start this add-in"
- Error installing custom functions
- Check if the affected user has the latest Excel version: SAP Analytics Cloud for Excel
- Check if Excel Cache is reset:
- After deployment, please reset the add-in cache:
- Windows:
- Web add-ins cache:
- Close all your Microsoft 365 apps, especially Outlook.
- Open Excel and go to File - Options - Trust Center - Trust Center Settings... - Trusted Add-in Catalogs .
- In Trusted Web Add-in Catalogs, select the check box Next time Office starts, clear all previously-started web add-ins cache.
- Close Excel and restart it to clear the add-in cache.
- After the restart, the check box is deselected automatically.
- Delete WEF folder: Go to %LOCALAPPDATA%\Microsoft\Office\16.0\Wef folder (except for webview2 folder) in the affected user machine
- Delete the cache under the path %LOCALAPPDATA%\Microsoft\Office\16.0\OfficeFileCache
- Reopen Excel click the “Add-ins” button on the far right side of the App ribbon. It should then reload the admin assigned add-ins.
- Web add-ins cache:
- Mac:
- 3616922 - How to delete SAP Analytics Cloud, add-in cache on Mac
- 3616922 - How to delete SAP Analytics Cloud, add-in cache on Mac
- Windows:
- After deployment, please reset the add-in cache:
- Local Browser:
- Check if third-party cookies are blocked:
- related error: builder panel empty
- related error: builder panel empty
- Check if third-party cookies are blocked:
- Check User Authorization:
- Tenant Level: SAC Related Authorization:
- Object: transaction data:
- SAC: Privileges and Permissions
- SAC: User
- SAC: Role
- SAC: Audit log:
- Object: Excel workbook:
- User needs to have Add-in Workbook permission configured in SAC tenant - Security
- Object: transaction data:
- Excel Level: Excel Workbook Authorization:
- Designer: all permissions: Create, Read and Update
- Viewer: Read permission assigned
- give designer permissions to viewers via workbook preferences
- read-only workbook: sample
- Allow editing in the Share dialog
- See more Permissions for the add-in
- Tenant Level: SAC Related Authorization:
- Functions:
- General Trouble-Shooting Rule:
- Check if the issue is reproducible via SAC Story
- If so, report the case under SAC functions
- If the issue is reproducible only with Excel add-in function, then report the case under SAP Analytics Cloud, add-in for Microsoft Excel
- Check if the issue is reproducible via SAC Story
- Data Point Comment
- SAP.GETDATACOMMENT
- Limit: Go to System ->Administration > System configuration -> Enable commenting on models with dimension members limit
- Related Error: Comments are not supported for this table since it has dimensions with members exceeding the admin configured limit; please contact your administrator
- Transaction Data:
- Live Connections:
- Related Error:
- An error occurred while loading the data sources of system <systemname>. Therefore, no data sources can be shown.
- 3511880 Error occurs when connecting SAP BW or SAP S/4HANA Tunnel type Live connection in SAC add-in for Microsoft Excel
- 3511880 Error occurs when connecting SAP BW or SAP S/4HANA Tunnel type Live connection in SAC add-in for Microsoft Excel
- An error occurred while loading the data sources of system <systemname>. Therefore, no data sources can be shown.
- Related Error:
- General Trouble-Shooting Rule:
- Traces and Logs:
- Windows:
- MS Admin: Verify if the office add-in is on MS central deployment
- MS Admin: in case you are using SAC domain other than standard domain hcs.cloud.sap, make sure SAC tenant URL(s) is listed in "AppDomains" in the powershell output and other settings required in tenant configuration; see sample in 3255665 - Tenant configuration when not using a standard domain hcs.cloud.sap
- Affected end user: go to Excel, click "Add-ins", then "more add-ins" button, check if SAC add-in exists
- Affected end user: go to Excel Home -> Add-ins -> More Add-ins, go to ADMIN MANAGED tab and My Add-in tab.
- Affected end user: go to Excel, click on "About Excel" button, to get a MS Excel version and MS channel info
- Affected end user: Console log and Network trace:
- See more in 3085993 - Troubleshooting guide for the SAP Analytics Cloud, add-in for Microsoft Office
- Affected end user: right click on the SAC Excel logon page(where the go button is) and click Inspect, then reproduce issue like click "Go!" button to get a console log(right click and save as) on console tab
- Affected end user: on the same devtool, go to network tab, get a network trace(export the HAR file)
- Mac:
- 3625313 - How to enable development tools in SAC add-in for Excel Desktop on Mac
- Microsoft documentation "Debug Office Add-ins on a Mac"
- WEF folder:
- Go to %LOCALAPPDATA%\Microsoft\Office\16.0\Wef folder (except for webview2 folder) in the affected user machine
- Zip and attach the files into the SAP case.
-
Enable runtime logging in Excel and check the log file for errors
See https://learn.microsoft.com/en-us/office/dev/add-ins/testing/runtime-logging (Analyzed by Microsoft)
- Windows:
- Check Memory Consumption
- task manager
- browser: development tool
- WebView2
- Understanding the Office Add-ins runtime
- Check if domains is accessible in cooperation network (for example: [assets.sapanalytics.cloud appsforoffice.microsoft.com hcs.cloud.sap])
- Future Release Plan
- 2937385 - Release Plan for SAP Analytics Cloud, add-in for Microsoft Excel
- 2937385 - Release Plan for SAP Analytics Cloud, add-in for Microsoft Excel
- Future Planned Functions:
- Submit Enhancement Request
- Influence Page for SAC: https://influence.sap.com/sap/ino/#/campaign/884
- Influence Page for SAC: https://influence.sap.com/sap/ino/#/campaign/884
- Submit a support case in SAP
- Before Submit:
- Microsoft 365 version and status:
- Test with latest add-ins version: Insert - Office Add-ins and insert the latest version of the add-in.
- Test with latest browser version
- Check if the issue is reproducible in local network/firewall/VPN/Azure Server..etc
- Check if the issue is related to local machine(test with other machine)
- Check if the issue is related to certain browser(Chrome, Edge, Safari)
- Check if the issue is related to certain user (test with admin or planning admin)
- Check if the same function is reproducible in SAC tenant
- Microsoft 365 version and status:
- Affected SAC tenant URL and Enable support user feature:
- Go to System > Administration > System Configuration page.
- Click the pencil (edit) icon.
- Search for “SAP Support”
- Enable the option to "Allow SAP Support User Creation".
- Affected workbook menu path/URL (attach the affected workbook into the case)
- Affected data source info(live connection: BW/S4HANA/DataSphere...etc, source system information)
- Steps to reproduce the issue
- Before Submit:
- Submit a Microsoft case.
See Also
Help Document: https://help.sap.com/docs/SAP_ANALYTICS_CLOUD_OFFICE
3085993 - Troubleshooting guide for the SAP Analytics Cloud, add-in for Microsoft Office
2937937 - The "Go!" button remains disabled when trying to logon to SAC in "SAC add-in for MS Office"
3679733 - SAP Analytics Cloud Add-in is not loading
3255665 - SAP Analytics Cloud tenant configuration and troubleshooting
3289328 - Deploying SAC add-in for Microsoft Office - when you do not have access to Microsoft Store
3021518 - Comment widget not displaying date dimension filter after chaning date filter in SAP Analytics Cloud (SAC)
Keywords
SAC Add-in, Login Blank Page, SAC, excel, login, URL, SAP Analytics Cloud, add-in for Microsoft Excel, SAP Analytics Cloud, add-in for Excel, https://hcs.cloud.sap https://*.live.com https://*.online.office.de https://*.sharepoint.com System Administration App Integration Trusted Origins blank, logon, login, desktop, not working, window, browser, ie, vpn memory limit Edge, Chrome or Safari memory consumption SAP Analytics Cloud, add-in, clear cache, Mac, Microsoft Excel ProductId 8a512e2b-c04e-4c06-9235-11b6cd59f584 OrganizationAddInOverrides AddInOverridesCreationException domain on *.officeapps.live.com AppDomains _OSF_PRIVATECATALOG_ADDINS ADMIN MANAGED MY ADD-INS landing Page Version landingPage office&landingPageVersion=1&addinVersion=1.21.0.0&addinName=ms-store&latestAddinVersion=1.21 SAP.GETDATACOMMENT Monthly Enterprise Channel Semi-Annual Enterprise Channel Publish Data, Revert Data, SAC, Excel, Add-In, table, workbook, Planning Enabled, turned on, turned off, enable, disable, parameter, option deploy excel addin add-in not loaded , KBA , LOD-ANA-OF-XLA , SAP Analytics Cloud, add-in for Microsoft Office , LOD-ANA-OF , SAP Analytics Cloud, add-in for Microsoft Office , LOD-ANA-PL , Planning , Problem
SAP Knowledge Base Article - Public