Symptom
When accessing the People Profile tab in an ESM case, you notice the SAP SuccessFactors profile displayed belongs to the Agent instead of the Requester of the case.
Environment
SAP Enterprise Service Management
Reproducing the Issue
- Logon to the SAP Enterprise Service Management tenant.
- Navigate to Self Service work list.
- Open any case.
- Navigate to People Profile tab.
- See the SAP SuccessFactors profile displays the agent profile (logged in user in ESM) rather than the profile of the requester.
Cause
This might happen in case the employee is mapped to the mashup parameter in the Mashup settings itself, rather than in the Case Details UI via the Adaptation Mode.
Resolution
Follow the steps below to adjust the mapping:
- Navigate to Self Service work list.
- Open any case.
- Navigate to People Profile tab.
- Click on the User Profile.
- Click Start Adaptation.
- Edit the mashup properties in the UI.
- Select the employee/employeeDisplayId in the mashup parameter.
- Click Apply.
Keywords
SF, SuccessFactors, Employee Portal, People Profile, Profile, People, ESM, Enterprise Service Management, V2, Version 2, Case, Tab, Mashup, Mashup Parameter, Parameter, Map, Mapping, Mapped, SAP Service Cloud Version 2, Cases, , KBA , CEC-CRM-SELF , ESM support for Self-Service module , CEC-CRM-MAS , Mashups for SAP Sales/Service Cloud , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-EMP , Employee for SAP Sales/Service Cloud , Known Error
SAP Knowledge Base Article - Public