SAP Knowledge Base Article - Public

3707387 - Field Last Response Date/Time inaccessible in PDI/SDK

Symptom

The 'Last Response Date/Time' field located at Surveys is not accessible from PDI/SDK.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Visit > Surveys > Surveys Tab in the SDK.
  2. Attempt to access the 'Last Response Date/Time' field from PDI and Observe that the field is not accessible and lacks an accessible association in the UI designer.

Cause

It is the expected behavior because the field "Last Response Date/Time" is not available in Data Source or accessible via PDI. This is due to the fact that it is a dedicated field within the UI Designer. As such, the value of this field is calculated within the CIP Class, which means it cannot be directly consumed from PDI.

Resolution

Currently that functionality is not available, if the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available

Keywords

survey, last response date/time, field inaccessible, pdi, ui designer, visit-surveys, surveys tab, SAP Cloud for Customer, SAP Sales Cloud, activity and visit management , KBA , LOD-CRM-ACT , Activities , AP-RC-BDS-SCR , ByDesign Studio Scripting (ABSL) , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions