Symptom
When selecting a specific Ticket Type, the Status field does not show all the Status options.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service > Tickets.
- Filter by All.
- Click on advanced search.
- Click on Status dropdown field.
- See all options are shown.
- Now on Ticket Type select the desired one.
- Now click on Status dropdown.
- Not all options are shown.
Cause
The Status field is being controlled by Ticket Type field via Code List Restriction (CLR). Even though there is no "Save" or "Go" action executed, still the CLR will work.
Resolution
- Go to Administrator > General Settings.
- Click on Code List Restrictions.
- Find the CLR which is restricting the Status via Ticket Type.
Keywords
CLR, rule, code list restriction, save, apply, go, run, statuses, ticket, service request, C4C, missing, miss, missed, disappears, disappear, not shown, not showing, hidden, hide, hiding, vanishes, vanish, vanished , KBA , LOD-CRM-SRP , Service Request Processing , AP-RC-UIF , C4C UI Framework , Problem
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public