Symptom
You notice that, after selecting a warranty while updating a Registered Product, the Warranty Start Date and Warranty End Date fields are populated, but the Warranty field remains blank / empty in the Registered Product header.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Logon to the SAP Service Cloud Version 2 tenant.
- Navigate to Registered Products work list.
- Open any record.
- Expand the header section.
- Click to edit the field Warranty.
- Select any active warranty in the pop-up.
- See the fields Warranty Start Date and Warranty End Date populate the data, but the field Warranty remains empty.
Cause
This may happen in case the Warranty has no description maintained for the logged in language, which causes it to be displayed as blank, when in reality it has been populated as expected.
Resolution
Ensure the description is maintained for all warranties in the language you are logged in, and upon selecting a warranty for a registered product, the field will then display the data properly.
Keywords
Warranty, Warranties, Registered, Product, Registered Product, RP, Field, Blank, Empty, No Data, Data, V2, Version 2, SAP Service Cloud Version 2, Description, Language, Login Language, , KBA , CEC-CRM-RPD , Registered Products for SAP Sales/Service Cloud , CEC-CRM-WAR , Warranty for SAP Sales/Service Cloud , How To
SAP Knowledge Base Article - Public