SAP Knowledge Base Article - Public

3709913 - Business Partner with Multiple Roles Causes Navigation Issue

Symptom

When User opens Owner from opportunity header, the system opens individual Customer instead of the Employee in production tenant.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales WC
  2. Go to Opportunity view
  3. Search Opportunity ID 'XXXX'
  4. Select the user "ABCD" under the Owner field in OWL > The users Employee facet opens
  5. Open the Opportunity, in the header select the owner "ABCD"> The Customer facet opens
  6. Expected Result: Should open Owner name - "ABCD" in Employee Facet in both scenarios

Cause

The same Business Partner ID (XXXXXXXXXX) is maintained with two roles.

The Business Partner ID is assigned with Employee and Account (Individual Customer) in system. 

Navigation is happening because Employee and customer roles are maintained on same business Partner ID, not because of the person's name.

SAP C4C determines navigation based on the roles assigned to Business Partner.

The behavior is as per system design.

Resolution

Suggested Approach:
Remove the Account role from Business Partner ID to avoid the behavior as business wants employee should be open. 

Keywords

Sales WorkCentre, Opportunity, Owner, Business Partner, Roles , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer core applications all versions