SAP Knowledge Base Article - Public

3710066 - User Marked as "Out of Validity Period" Can Still Log In to SAP S/4HANA Puublic Cloud Systems

Symptom

  • The user validity date has expired; however, system access is not restricted as expected.
  • Although the status is displayed as “Out of Validity Period”, the user is still able to log in on the validity end date.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Set the "Valid To" date for a user to today's date in the Maintain Business Users application.
  2. Observe status showing as "Out of Validity Period" for the user.
  3. Attempt to log in with the user on the same day.
  4. Confirm that the user is still able to log in successfully.

Cause

The "Valid To" date specifies that the user is valid until the end of the specified date, based on the system's time zone (UTC+0) unless the time is set by the administrator.

Resolution

The Valid To date ensures that a user remains valid until the end of the specified day, based on the system time zone. It is not possible to define a specific time; only the date can be maintained.

In addition, the Maintain Business Users app has been enhanced to align the displayed status with the actual system behavior. As of release 2602, the status “Out of Validity Period” is no longer shown on the final day of the user’s validity.

Keywords

validity period, out of validity, SAP S/4HANA Cloud, user access, validity end date, maintain business users, identity and access management, UI misleading, validity inclusive, user login , KBA , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions