Symptom
Custom Manager is not accessible within Recruit to Hire data mapping for JobRelationsInfo.
Reproducing the Issue
1.Go to Recruit to Hire Data Mapping Admin Center Tool
2.Go to JobRelationsInfo
3.Click + sign and Custom Manager is not an option
Cause
For two picklist non unique external code were same. Hence, it is causing the issue.
Resolution
The problem was due to non‑unique external codes. Both the Technical Manager and Custom Manager roles were using the same external code, which caused the system to render only one of them.
Each external code in the jobRelType picklist must be unique to avoid conflicts.
See Also
Keywords
Picklist, Picklist center, JobRelationsInfo, ONB 2.0, OBX, Dropdown, external code. , KBA , LOD-SF-OBX , Onboarding 2.0 , Problem
Product
Attachments
| image (41).png |
| image (40).png |
SAP Knowledge Base Article - Public