SAP Knowledge Base Article - Public

3710271 - Job application visibility issue when Status is updated via API - Recruiting Management

Symptom

Using API, job application is moved to another Status (e.g. Interview). However recruiting user(s) cannot see the job application in that status.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Using API, update the Status of a job application
  2. Proxy as operator who have visibility to the Status
  3. Operator cannot see the job application

Cause

The application was moved via API into an incorrect Status ID, which does not exists in the Status Set linked to the Job Requisition template.

Resolution

Confirm the correct Status ID by going to Edit Applicant Status Configuration and then open the Status Set that's linked to the Job Requisition:

Next, update the application's Status ID into correct one via API or Integration Center. For reference see KBA 2883239 - How to update the Application Status via Integration Center/OData API - Recruiting Management.

See Also

2080952 - Applicant Status Configuration in SuccessFactors - Recruiting Management

Keywords

job application visibility, missing, operator role, status id, status set, status id , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions