Symptom
When adding a new item line in the sales order, after entering the product ID, the Contract Items field is enabled. From the value help, there is no record found.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Create a new sales order and enter the account ABC in General tab.
- In Items tab, add a new row and enter the product ID XYZ, the Contract Item field is then enabled.
- Open the value help list, there is no record found. Not able to assign any contract item to the sales order line.
- ABC represents the account ID.
- XYZ represents the product ID.
Cause
The Contract Item field in the sales order line will propose the active contract items matching the following conditions:
- The account in both contract and sales order are the same.
- The product in both contract item and sales order item are the same.
- The item status of the contract item is In Process and the delivery status is not Finished/Cancelled.
In this case, there is no active contracts with account=ABC and product=XYZ, hence, it is not listed in the Contract Item field value help list.
Resolution
It is the designed system behavior.
Keywords
sales order; create with reference to contract; Contract Item; no record; contract item missing; missing. , KBA , AP-SLO-SO , Sales Order , Problem
SAP Knowledge Base Article - Public