SAP Knowledge Base Article - Public

3710832 - The Opportunity's Account is Automatically Updated After Changes in the Sales Partner

Symptom

When changing the name of the Sales Partner ABC in its master data from an opportunity, the opportunity's account is updated to ABC

(Where ABC represents the relevant Sales Partner ID).

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Navigate to the New Business workcenter.
  2. Go to the Opportunities view.
  3. Search for the relevant opportunity.
  4. Select it and click on the Edit button. The account is XYZ (XYZ represents the account ID maintained in the opportunity at first)
  5. Go to the Involved Parties tab.
  6. Select the Sales Partner ABC and double click the party role's hyperlink. The master data of the Sales Partner will be open.
  7. Click on View All.
  8. Edit the Account's First Name.
  9. Click on Save and Close.

The Opportunity's account, which was previously XYZ, has now changed to ABC automatically.

Cause

When changing the name of a Sales Partner from the opportunity and clicking on the 'save and close' button, an event is triggered from the Account to the Opportunity in the backend, which replaces the opportunity's account for the changed Sales Partner. Hence, the error occurs.

Resolution

This is the current system behavior.

There is no feasibility to differentiate the Sales Partners from the account triggering updates to the opportunity. Therefore, this is technical limitation of SAP Business ByDesign.

To avoid the issue, the account should be reset whenever a Sales Partner is changed from the opportunity. Alternatively, the party roles can be accessed and updated from their respective workcenters (not from the opportunity). This way, the changes will not modify the opportunity's Account.

Keywords

Party Roles, opportunity, automatically changed, account, involved parties, new business, sales partner, marketing, master data, byd. , KBA , SRD-CRM-MKT , Marketing , How To

Product

SAP Business ByDesign all versions