SAP Knowledge Base Article - Public

3710861 - Error in Data Import Update: The mapper [com.sap.crm.dataimpexservice.service.BatchService$$Lambda$] returned a null value

Symptom

Error to update data using Data Import and Export tool: "The mapper [com.sap.crm.dataimpexservice.service.BatchService$$Lambda$] returned a null value."

Environment

SAP Sales and Service Cloud Version 2

Cause

There are some records in the import file without the technical ID.

Resolution

For import update, the recommended approach is to export the records. When the file is downloaded, make the desired changes in the template. For all other fields, do not remove them. The import update will detect any changes made in the template and update. The technical ID field is mandatory for import update.

Please export the records again. Then, re import and make sure the technical ID field is not erased.

Keywords

Mapper, Data import, update, null, technical , KBA , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0