Symptom
- The issue involves defining a new routing rule for the Activity Plan.
- The object being created is "Visit".
- A new condition needs to be added using the "Document Type" field for filtering.
- The values displayed are incorrect; instead of Visit Types, the list of Business objects is shown.
- The issue is specific to "Visit" routing rules, as other objects function correctly.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite:- Various types of Visit Types are configured in the Fine tuning activities.
- Go to Activities work center.
- Go to Routing Rules work center view.
- click on + to create new routing rule for visit.
- Save the Routing Rule.
- Open and edit Routing Rule.
- Add a new condition using the "Document Type" field for filtering.
- Observe that the values displayed are not Visit Types which are configured, instead displays the list of business objects in C4C.
Cause
- Incorrect filter is selected when defining conditions for the rule.
- The "Document Type" field for filtering provides various documents like opportunity, sales quote, lead, etc and does not display Visit Types.
Resolution
- Define the condition for "Visit" using the filter "Visit Type" instead of "Document Type".
- Verify that the expected result of showing Visit Type documents defined in the configuration is achieved.
See Also
Keywords
routing rule, visit object, document type, visit type, activity plan, filter condition, C4C, rule definition, Visit Routing, Visit configuration , KBA , LOD-CRM-ACT-ROT , Activity Routing , LOD-CRM-ACT-VST , Visit Planning , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public