SAP Knowledge Base Article - Public

3710960 - error "can't connect to hana cloud" when creating a live connection to hana cloud in sap analytics cloud

Symptom

  • Error message: "Can't connect to HANA cloud" is displayed when attempting to create a live connection to HANA cloud in SAP Analytics Cloud.
  • SAML Identity provider configuration has been completed in SAP Analytics Cloud and metadata updated in HANA cloud.
  • SAC live connection with SSO to another HANA cloud instance works correctly.

Environment

  • SAP Analytics Cloud 2025.21.11

Reproducing the Issue

  1. Attempt to create a live connection to HANA cloud in SAP Analytics Cloud.
  2. Configure the SAML Identity provider in SAP Analytics Cloud and update the metadata in HANA cloud.
  3. Observe the error message: "Can't connect to HANA cloud." Below error can be confirmed from HAR trace:
    Error while getting JDBC connection due to invalid credentials. Request Type: HANA_CLOUD, Tenant UUID: XXXXXXXXXXXXXXXX, URL: XXXXXXXXXXXXXXXXXX.hana.prod-ca10.hanacloud.ondemand.com

Cause

  • One of the HANA cloud instances had two authentication methods enabled, which caused the connection issue.

Resolution

  1. Verify the authentication methods enabled for the HANA cloud instance.
  2. Ensure that only the SAML Identity provider is selected as the authentication method for the HANA cloud instance.
  3. Test the connection to confirm successful resolution.

See Also

Keywords

hana cloud, sac, live connection, saml sso, authentication methods, metadata, error message, can't connect to hana cloud, sap analytics cloud, live data connection, troubleshooting, connection issue, sac hana , KBA , LOD-ANA-LDC-HAN , SAC Live Data Connection HANA , Problem

Product

SAP Analytics Cloud all versions