SAP Knowledge Base Article - Public

3711384 - Lead Action Convert to Opportunity Grayed Out

Symptom

The Convert to Opportunity option is grayed out for the Key Test User, while it is enabled for the Admin User for the same lead.

Environment

SAP Cloud for Customer 

Reproducing the Issue

  1. Log in to the system using the Key Test User.
  2. Navigate to the Sales Work Center.
  3. Open the Leads view.
  4. Open a lead that needs to be converted to an opportunity.
  5. Observe that the Convert to Opportunity option is grayed out.

Note: The same lead can be converted to an opportunity when logged in as Admin User.

Cause

• There could be multiple reasons for this issue.

• One reason is that the Account_Creation action is set to Disabled under the Field & Action tab in the business role assigned to the affected user. 

Resolution

Enable Account_Creation in the Field & Action tab of the relevant business role.
After this change, the Convert to Opportunity option becomes available for the affected user

Keywords

Convert to opportunity, Leads, Grayed out , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer core applications 2508 ; SAP Cloud for Customer core applications 2602