Symptom
The Convert to Opportunity option is grayed out for the Key Test User, while it is enabled for the Admin User for the same lead.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log in to the system using the Key Test User.
- Navigate to the Sales Work Center.
- Open the Leads view.
- Open a lead that needs to be converted to an opportunity.
- Observe that the Convert to Opportunity option is grayed out.
Note: The same lead can be converted to an opportunity when logged in as Admin User.
Cause
• There could be multiple reasons for this issue.
• One reason is that the Account_Creation action is set to Disabled under the Field & Action tab in the business role assigned to the affected user.
Resolution
Enable Account_Creation in the Field & Action tab of the relevant business role.
After this change, the Convert to Opportunity option becomes available for the affected user
Keywords
Convert to opportunity, Leads, Grayed out , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-OPP , Opportunity Management , Problem
SAP Knowledge Base Article - Public