SAP Knowledge Base Article - Public

3711446 - Dropdown fields in job information stuck on "loading..." for specific users in SAP SuccessFactors Employee Central

Symptom

Dropdown fields display "Loading…" indefinitely without returning values for specific users.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Log in as one of the affected users.
  2. Navigate to a Portlet like Job Information.
  3. Attempt to access a dropdown field within Job Information.
  4. Observe the dropdown displaying "Loading…" indefinitely without returning values.

Cause

The picklist value is not displaying because a translation does not exist for the login user’s default locale.

Resolution

Steps to change the default locale when there's only one affected user:

  1. Select the 'Settings' option in the main menu.
  2. Open 'Change Language' and select a Language with an available translation, then save.
  3. Ensure the user performs these steps while logged in with their own account, as proxying will not work.

IF there are more than one affected user, the recommended approach would do this change through basic import or insert the missing translation for the picklist value.

See Also

Importing Basic User Data | SAP Help Portal

Keywords

dropdown stuck, loading indefinitely, job information, picklist issue, en_GB locale, SAP SuccessFactors Employee Central, user-specific issue, console error, getList deprecated, locale change, translation, language, loading, field , KBA , LOD-SF-EC-JOB-PKL , Picklists , Problem

Product

SAP SuccessFactors Employee Central all versions