Symptom
- Translation cannot be added to survey answer options.
- Only login language is available when attempting to add translation entries to survey answer options.
- Globe button does not allow selection of other languages.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Login to the system in English.
- Navigate to the Surveys workcenter.
- Search for and open target Survey.
- Go to the Design Facet and click Edit.
- Open the target question, scroll down to Answer options, and click Add.
- Enter text and click the Globe Icon.
- Observe that only English is available, and it is not possible to add another language.
Cause
Language is determined by the login language.
Resolution
- Log into the system using a different language, e.g., Deutsch.
- Navigate to the Surveys workcenter and open the target survey.
- Go to the Design Facet and click Edit.
- Open the target question, scroll down to Answer options, and click Add.
- Enter text and click the Globe Icon.
- The language shown is Deutsch.
- Enter translation and save.
- Repeat for desired language translations
Keywords
survey, translation, answer option, globe button,, login language, survey design, translation issue, language selection, answer option translation, survey answer , KBA , LOD-LE-SUR , Survey , How To
Product
SAP Cloud for Customer core applications all versions
SAP Knowledge Base Article - Public