Symptom
Lead Status Changes From “Converted” to “Qualified” When Creating an Activity During Lead Conversion
Environment
SAP Cloud for Customer
Reproducing the Issue
Log in to the system: myXXXXX.crm.ondemand.com.
Navigate to Sales WC.
- Open Lead WCV.
- Open any Lead ID.
- Navigate to the Activities section of the Lead.
- Click New under any activity type (Phone Call / Appointment / Task / Email).
Scenario 1
- Start creating the activity but do not save it.
- While the activity creation screen is still open, navigate back to the Lead.
- Convert the Lead.
- Return to the activity creation screen and save the activity.
- Observe that the Lead Status changes from “Converted” to “Qualified”.
Scenario 2
- From the Lead, click Convert Opportunity.
- Do not finalize the conversion.
- Navigate back to the Lead.
- Click New under Activities and start creating an activity.
- Navigate back to the conversion screen and complete the Lead conversion.
- Return to the activity creation screen and save the activity.
- Observe that the Lead Status changes from “Converted” to “Qualified”.
Cause
This issue occurs because saving or creating an activity after lead conversion triggers a system update that re-evaluates the lead status, causing it to automatically revert from Converted to Qualified.
Resolution
To avoid the lead status reverting from Converted to Qualified, ensure that the lead conversion process is fully completed before creating or saving any new activities (such as phone calls, tasks, appointments, or emails) for that lead. By completing the conversion first, the system will correctly retain the Converted status, and subsequent activity creation will not trigger the automatic status update.
See Also
NA
Keywords
Lead Status, Activity Creation, Qualified Lead, Converted Lead. , KBA , LOD-CRM-LM , Lead Management , Problem
SAP Knowledge Base Article - Public