Symptom
Accounts assigned with Party role are not visible to users
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the account management work center.
- Select Accounts view
- Select "All accounts" from the dropdown menu.
- Search for account numbers XXXXX
- Observe that no data is displayed for these accounts.
Cause
The direct responsible employee assigned to the custom party role does not have the BPM_ACCOUNTS work center view assigned, which restricts account visibility.
Resolution
- Assign the workcenter view id BPM_ACCOUNTS in access restriction to the Direct responsible employee maintained for party role
- Additionally check the detailed restriction tab in Access rights if the employee has any restriction maintained and the employee is available in detailed restricted Access group id.
- If not available then the correct Org unit should be assigned to employee with required access.
See Also
Keywords
sales central role, account management, account visibility issue, BPM_ACCOUNTS, party role assignment, direct responsible employee, identity & access management, account restrictions, work center view, SAP Business ByDesign , KBA , SRD-CC-IAM , Identity & Access Management , AP-ACC , Business ByDesign: Financial Accounting , AP-OM , Organisational Management , Problem
SAP Knowledge Base Article - Public