Symptom
You are replicating Employees from SAP S4HANA to SAP Sales & Service Cloud V2 and the messages in monitor fail with error "Gender XYZ does not match the title ABC". XYZ is the standard Gender Type and ABC is the standard or custom Title.
Environment
SAP Sales & Service Cloud V2 Integration with SAP S4HANA
Reproducing the Issue
- Go to COD_INT_MENU in your SAP S4HANA or SAP ERP System
- Execute "Load or Resend Employees"
- Open the Message Monitor and check the failed message
Cause
- Default Gender Categories in Sales & Service Cloud V2 are "Male", "Female", "Gender Not Specified" and the Title you are sending doesnt match the Gender category.
- For example you are sending Ms as Title and Male as Gender - you get this error message
Resolution
- If you are creating custom Title under Settings >> Business Partners >> Titles , ensure you chose proper value under "Related Gender Code".
- If the issue is with incorrect combination sent from S4HANA or ERP , then correct the data because in Sales & Service Cloud v2, we have validation for the combination of Gender Code and Title(Academic Title Code)
Keywords
message monitoring, gender code mismatch, title mapping error, inbound-data-connector.132, replication error, SAP Sales Cloud, SAP Service Cloud, employeeS4ReplicationMessageIn, Z003, gender not specified, non-binary, integration error. , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0
SAP Knowledge Base Article - Public