SAP Knowledge Base Article - Public

3712546 - Business Partner Roles are missing in Maintain Business Partner app

Symptom

Unable to find or assign the required roles to the Business Partner in Maintain Business Partner app.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to app Maintain Business Partner.
  2. Enter the Business Partner in the Business Partner field.
  3. Click on Start.
  4. Double click on the line item of the partner.
  5. The roles are missing in the drop down of field Display in BP role.

Cause

The Business Partner role is not visible because it has been hidden in configuration activity.

Resolution

In configuration activity 103008 – Define BP Roles, the Hide checkbox is selected under General Data for the respective Business Partner role. As a result, the roles are not visible for the Business Partner.

Follow below steps for configuring in Manage Your Solution' app: 

  1. Go to app Manage Your Solution.
  2. Select the configuration Activity 103008 - Define BP Roles.
  3. Click on Configure.
  4. Double click on the BP role.
  5. Uncheck the check box Hide under General Data.
  6. Save the entry.

Incase while using SAP Central Business Configuration (CBC) :

  1. Log on to the project experience in SAP Central Business Configuration.
  2. Select the relevant project.
  3. Navigate to the configurations activity tab. 
  4. Search for the configuration activity '103008 - Define BP Roles'.
  5. Select the configuration activity to navigate directly to the SAP S/4HANA Cloud system.
  6. Double click on the BP role.
  7. Uncheck the check box Hide under General Data.
  8. Save the entry.

Keywords

missing role, manage business partner master data,  maintain business partner, BP role tab, SAP S/4HANA Cloud Public Edition, business partner roles, role navigation, standard system behavior, role visibility, app ID BP , KBA , LO-MD-BP-2CL , Business Partners for Public Cloud , Problem

Product

SAP S/4HANA Cloud Public Edition all versions