Symptom
G/L Account field is missing when using the CDS view I_HouseBankAccountLinkage to retrieve bank account details.
Environment
SAP S/4HANA Cloud Public Edition 2602
Reproducing the Issue
- Access the Customer Data Browser app or use a custom analytical query.
- Select the CDS view I_HouseBankAccountLinkage.
- Execute the view to verify available columns.
- Observe that G/L Account mapping field is not displayed in the results.
Cause
The issue is caused by a structural inconsistency between the underlying CDS view and the Customer Data Browser Object (CDBO). While new fields were introduced to the I_HouseBankAccountLinkage view in 2022, the corresponding metadata for the Customer Data Browser was not synchronized. Consequently, these fields remain hidden in the application layer even if they exist in the database view.
Resolution
A standard code correction will be delivered to synchronize the CDBO with the updated CDS view structure.
The fix is scheduled to be delivered in the CE2602.2 update on March 12, 2026.
Keywords
cds view, house bank, general ledger account, sap s/4hana public cloud, I_HouseBankAccountLinkage, structural inconsistency, CDBO, missing fields, bank account linkage, CE2602.2, finance. , KBA , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , Product Enhancement
SAP Knowledge Base Article - Public