Symptom
A Billing invoice with Types 'Pro forma' is created based on a Sales Order. However, there is no eDocument created in the eDocument Cockpit.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open VF03.
- Search for the Billing Invoice.
- Open it, then you will understand the document type is 'Pro forma' relevant.
- Choose the button Display Document Flow, you will see it is created based on a Standard Sales Order and no Journal Entry follows it.
- Open the eDocument Cockpit APP.
- Choose the button Changes.
- Navigate to the Billing Document Tab.
- Fulfill the company code and the document ID.
- Mark the indicators 'With Errors', 'Not Yet Created' and 'Not Relevant'.
- Choose the button Execute, no eDocument available would show in the result.
Cause
For the process Electronic Customer Invoices: Tax Authority Clearance in Malaysia, the system determines the eDocument types and their creation using the setup defined in SSCUI Assign eDocument Type to Accounting Document Type, rather than the Billing Document Type. As a result, an electronic invoice will only be generated if the corresponding electronic invoice type is properly maintained in the SSCUI Assign eDocument Type to Accounting Document Type after the accounting document has been created.
NOTE: While Assigning eDocument Type to Billing Document Type (Mandatory)| SAP Help tells about the scenario of the creation of electronic documents when a billing document without journal entry is posted, this is not supported in the current version of Malaysia.
Resolution
As the Billing invoice with Types 'Pro forma' is generated from a Sales Order, it is expected that no journal entry is created within the document flow, and no accounting document is produced. Consequently, this means that no corresponding e-invoice will be generated in the eDocument Cockpit.
See Also
Keywords
Malaysia, eDocument, E-invoice, Creation, Generation, Billing Document, F5, F8, Pro forma, Accounting Document, Document Type , KBA , CA-GTF-CSC-EDO-MY , Malaysia , Problem
SAP Knowledge Base Article - Public