SAP Knowledge Base Article - Public

3713718 - Error "Recipient role with id '/RULE/MRM_AG_BADI' cannot be resolved"

Symptom

Error “Recipient role with id ‘/RULE/MRM_AG_BADI’ cannot be resolved.” is faced when clicking on save as complete.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Log in to the SAP system with a user who processes supplier invoices.

  2. Navigate to the Supplier Invoice processing application (e.g., FB60, MIRO, or Fiori App “Create Supplier Invoice” — depending on customer setup).

  3. Open the supplier invoice XYZ. (XYZ means supplier invoice ID)

  4. Attempt to submit the invoice for approval via the workflow action (e.g., SubmitPark and CompleteSend for Approval).

  5. The system attempts to trigger the workflow for the invoice.

  6. The following error message is displayed:
    “Recipient role with id '/RULE/MRM_AG_BADI' cannot be resolved.”

Cause

It is necessary to check with customer's development team.

Resolution

The error "Recipient role with id '/RULE/MRM_AG_BADI' cannot be resolved" was occurred because your custom code in BADI MRM_WORKFLOW_AGENTS cannot determine workflow recipient properly. Also, is necessary assign any business user (CB user which has Business Partner) as approver.

The custom code falls outside of scope of product support.

Keywords

BAdI, Supplier Invoice, MRM_WORKFLOW_AGENTS, /RULE/MRM_AG_BADI, Workflow, Supplier Invoice Workflow. , KBA , MM-FIO-IV-2CL , Fiori UI for Invoice Verification (Public Cloud) , How To

Product

SAP S/4HANA Cloud Public Edition all versions