Symptom
Error “Recipient role with id ‘/RULE/MRM_AG_BADI’ cannot be resolved.” is faced when clicking on save as complete.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
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Log in to the SAP system with a user who processes supplier invoices.
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Navigate to the Supplier Invoice processing application (e.g., FB60, MIRO, or Fiori App “Create Supplier Invoice” — depending on customer setup).
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Open the supplier invoice XYZ. (XYZ means supplier invoice ID)
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Attempt to submit the invoice for approval via the workflow action (e.g., Submit, Park and Complete, Send for Approval).
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The system attempts to trigger the workflow for the invoice.
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The following error message is displayed:
“Recipient role with id '/RULE/MRM_AG_BADI' cannot be resolved.”
Cause
It is necessary to check with customer's development team.
Resolution
The error "Recipient role with id '/RULE/MRM_AG_BADI' cannot be resolved" was occurred because your custom code in BADI MRM_WORKFLOW_AGENTS cannot determine workflow recipient properly. Also, is necessary assign any business user (CB user which has Business Partner) as approver.
The custom code falls outside of scope of product support.
Keywords
BAdI, Supplier Invoice, MRM_WORKFLOW_AGENTS, /RULE/MRM_AG_BADI, Workflow, Supplier Invoice Workflow. , KBA , MM-FIO-IV-2CL , Fiori UI for Invoice Verification (Public Cloud) , How To
SAP Knowledge Base Article - Public