Symptom
Some existing content that has been working for a while, unexpectedly errors out and does not load the content. After launching the content the error may show:
- Internal Server Error - Read The server encountered an internal error or misconfiguration and was unable to complete your request.
A network trace shows a redirect to https://errors.edgesuite.net.
Environment
SAP SuccessFactors Learning
Cause
The root cause of the issue is on customers using legacy entitlement in the Launch URL of the content. This can be verified by going to:
- Learning Administration > Content > Content Objects
- Search and access the Content Object that is facing issues > Launch Method tab
- Check if the Content URL value has something like:
- iContent.plateau.com
- icontent.plateau.com
- IContent.plateau.com
These are not supported configurations.
Resolution
To resolve the issue with the Content Objects go to:
- Learning Administration > Content > Content Objects
- Search and edit the Content Object that is facing issues > Launch Method tab
- Update the Content URL field from icontent.plateau.com to <tenantid>.plateau.com (The tenantID value can be found in the browser search bar)
- Apply Changes
The same action needs to be done on the Deployment Location by going to:
- Learning Administration > System Administration > Configuration > Content Deployment Locations
- Search and edit the Deployment Location(s)
- Update the URL Prefix from icontent.plateau.com to <tenantid>.plateau.com
- Apply Changes
Any future imported content will not face the error. This change is not required if the URL Prefix for the Content Objects and/or Deployment Location are using the standard URL Prefix values as mentioned in KBA 2396085.
See Also
icontent, akamai, error, edgesuite, used, to, worked, before, prior, not, launching, content, object, item, training, lms, sf
Keywords
KBA , LOD-SF-LMS-CNT , Content , LOD-SF-LMS-PCM , iContent , Problem
SAP Knowledge Base Article - Public